For users of Microsoft Classic Outlook and Templafy Email Signature Web Add-ins, there may be occasions where signatures take a long time to insert into the email or are not inserted at all. This article explains the cause, solution (workarounds), and additional tools for further troubleshooting with Templafy in order to share them with Microsoft.
How do I know if I am using the Email Signature Web Add-in?
If the Templafy Email Signature icon is available on email composition, then the Web Add-in is being utilized.
Cause
The signature insertion problem is caused by an issue in Office.js and has been reported by Templafy engineers to Microsoft here: https://github.com/OfficeDev/office-js/issues/5124.
Solution
Customers experiencing the issue should upgrade their Office apps to the Monthly Enterprise Channel (>= Version 2411, Build 18227.20240). If an upgrade is not possilbe for your organization, please see other workarounds below.
Workarounds
Templafy is waiting for Microsoft to fix the issue on the Office versions < 2411, Build 18227.20240.
- Open the Email Signature task pane: Clicking on the Templafy Email Signature icon mentioned above will open the task pane and allow for signature insertion.
- Switch to New Outlook / Outlook Online: To switch to New Outlook, please follow the guide here. Your organization may have removed the ability to try New Outlook.
- Deploy Email Signature VSTO Add-in (via Templafy Desktop): The VSTO Add-in will take over responsibility of signature creation and insertion in Classic Outlook.
Please submit a support ticket to Templafy Support who will be able to assist with any of the above workarounds.
Continued troubleshooting
Templafy Support would like to collect log files from affected users to pass along to Microsoft. Once the logs have been collected, please submit a support ticket to Templafy Support of the problem and the name of the affected user where the log files have been obtained from.
Enable mail log messages
- Open the Templafy Email Signature task pane.
- Click the 3 dots and navigate to Settings:
- Check the Enable mail log messages checkbox and hit Save:
Settings are only applied to new emails after saving, so make sure to close the current email and start a new one before gathering the log.
Enable Runtime logging
This will create one log file that is reinitialized for each Outlook session. Restarting Outlook will erase all information logged in the file. The log file contains information from all the Web Add-ins that run in Outlook, not only Templafy's. The file could contain:
- Error messages explaining why the add-in does not work as expected.
- Extended behavioral logging from our add-in.
You can find the Microsoft guide here.
To enable runtime logging, follow the steps below:
- Open Registry Editor and navigate to
Computer/HKEY_CURRENT_USER/SOFTWARE/Microsoft/Office/{{YOUR_MAJOR_OFFICE_VERSION}}/WEF/Developer/RuntimeLogging
. - Add a new key called 'RuntimeLogging' with the value set to
{{anywhere in the computer}}\outlook-logs.txt
: - Once the desired behavior has been replicated in Outlook, send the file above to Templafy Support.
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